Privilege escalation in Cisco AMP for Endpoints



Published: 2017-10-24
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2017-12317
CWE ID CWE-264
Exploitation vector Local
Public exploit N/A
Vulnerable software
Subscribe
Cisco AMP for Endpoints
Client/Desktop applications / Antivirus software/Personal firewalls

Vendor Cisco Systems, Inc

Security Advisory

This security advisory describes one low risk vulnerability.

1) Privilege escalation

Risk: Low

CVSSv3.1: 7.7 [CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2017-12317

CWE-ID: CWE-264 - Permissions, Privileges, and Access Controls

Exploit availability: No

Description

The vulnerability allows a local attacker to gain elevated privileges on the target system.

The weakness exists in the Cisco AMP For Endpoints application due to the use of a static key value stored in the application used to encrypt the connector protection password. A local attacker can gain local, administrative access to a Windows host and stop the Cisco AMP for Endpoints service.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Cisco AMP for Endpoints: 3.1(10), 3.1(15), 4.0(0), 4.0(1), 4.0(2), 4.1(0), 4.1(1), 4.1(4), 4.2(0), 4.2(1), 4.3(0), 4.3(1), 4.4(0), 4.4(1), 4.4(2), 4.4(4), 5.0(1), 5.0(3), 5.0(5), 5.0(7), 5.0(9), 5.1(1), 5.1(3), 5.1(5), 5.1(7), 5.1(9), 5.1(11), 5.1(13), 6.0(1)

CPE External links

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20171020-ampfe

Q & A

Can this vulnerability be exploited remotely?

No. This vulnerability can be exploited locally. The attacker should have authentication credentials and successfully authenticate on the system.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###