Protection mechanism failure in Cisco AMP for Endpoints



Published: 2018-04-23 | Updated: 2018-04-23
Risk Low
Patch available YES
Number of vulnerabilities 1
CVE ID CVE-2018-0237
CWE ID CWE-693
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
Cisco AMP for Endpoints
Client/Desktop applications / Antivirus software/Personal firewalls

Vendor Cisco Systems, Inc

Security Advisory

This security advisory describes one low risk vulnerability.

1) Protection mechanism failure

Risk: Low

CVSSv3.1: 6.4 [CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:U/RL:O/RC:C] [PCI]

CVE-ID: CVE-2018-0237

CWE-ID: CWE-693 - Protection Mechanism Failure

Exploit availability: No

Description

The vulnerability allows a remote unauthenticated attacker to bypass security restrictions.

The weakness exists in the file type detection mechanism due to the software relies on only the file extension for detecting DMG files. A remote attacker can send a DMG file with a nonstandard extension to a device that is running an affected AMP for Endpoints macOS Connector and bypass configured malware detection.

Mitigation

Install update from vendor's website.

Vulnerable software versions

Cisco AMP for Endpoints: 1.4(5)

CPE External links

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180418-amp

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.



###SIDEBAR###