Show vulnerabilities with patch / with exploit

Multiple vulnerabilities in Symmetricom SyncServer



Published: 2020-02-19
Severity Medium
Patch available NO
Number of vulnerabilities 7
CVE ID CVE-2020-9028
CVE-2020-9034
CVE-2020-9033
CVE-2020-9032
CVE-2020-9031
CVE-2020-9030
CVE-2020-9029
CWE ID CWE-79
CWE-384
CWE-22
Exploitation vector Network
Public exploit N/A
Vulnerable software
Subscribe
SyncServer
Server applications / Other server solutions

Vendor Microsemi

Security Advisory

1) Stored cross-site scripting

Severity: Low

CVSSv3: 5.6 [CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:U/RL:U/RC:C] [PCI]

CVE-ID: CVE-2020-9028

CWE-ID: CWE-79 - Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Exploit availability: No

Description

The disclosed vulnerability allows a remote attacker to perform cross-site scripting (XSS) attacks.

The vulnerability exists due to insufficient sanitization of user-supplied data. A remote attacker can permanently inject and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

Successful exploitation of this vulnerability may allow a remote attacker to steal potentially sensitive information, change appearance of the web page, perform phishing and drive-by-download attacks.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

SyncServer: S100 - 2.90.70.3, S200 - 1.30, S250 - 1.25, S300 - 2.65.0, S350 - 2.80.1

CPE External links

https://sku11army.blogspot.com/2020/01/symmetricom-syncserver_95.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

2) Sesson Fixation

Severity: Medium

CVSSv3: 6.7 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:U/RL:U/RC:C] [PCI]

CVE-ID: CVE-2020-9034

CWE-ID: CWE-384 - Session Fixation

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform session fixation attacks.

The vulerability exists due to incorrect session handling. A remote attacker can gain unauthorized acces to victim's session and compromise the device.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

SyncServer: S100 - 2.90.70.3, S200 - 1.30, S250 - 1.25, S300 - 2.65.0, S350 - 2.80.1

CPE External links

https://sku11army.blogspot.com/2020/01/symmetricom-syncserver_27.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

3) Path traversal

Severity: Medium

CVSSv3: 4.9 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:U/RL:U/RC:C] [PCI]

CVE-ID: CVE-2020-9033

CWE-ID: CWE-22 - Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform directory traversal attacks.

The vulnerability exists due to insufficient sanitization of user-supplied passed the FileName parameter to the syslog.php. A remote attacker can send a specially crafted HTTP request containing directory traversal sequences and read contents of arbitrary files on the system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

SyncServer: S100 - 2.90.70.3, S200 - 1.30, S250 - 1.25, S300 - 2.65.0, S350 - 2.80.1

CPE External links

https://sku11army.blogspot.com/2020/01/symmetricom-syncserver.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

4) Path traversal

Severity: Medium

CVSSv3: 4.9 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:U/RL:U/RC:C] [PCI]

CVE-ID: CVE-2020-9032

CWE-ID: CWE-22 - Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform directory traversal attacks.

The vulnerability exists due to insufficient sanitization of user-supplied passed the FileName parameter to the syslog.php. A remote attacker can send a specially crafted HTTP request containing directory traversal sequences and read contents of arbitrary files on the system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

SyncServer: S100 - 2.90.70.3, S200 - 1.30, S250 - 1.25, S300 - 2.65.0, S350 - 2.80.1

CPE External links

https://sku11army.blogspot.com/2020/01/symmetricom-syncserver.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

5) Path traversal

Severity: Medium

CVSSv3: 4.9 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:U/RL:U/RC:C] [PCI]

CVE-ID: CVE-2020-9031

CWE-ID: CWE-22 - Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform directory traversal attacks.

The vulnerability exists due to insufficient sanitization of user-supplied passed the FileName parameter to the syslog.php. A remote attacker can send a specially crafted HTTP request containing directory traversal sequences and read contents of arbitrary files on the system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

SyncServer: S100 - 2.90.70.3, S200 - 1.30, S250 - 1.25, S300 - 2.65.0, S350 - 2.80.1

CPE External links

https://sku11army.blogspot.com/2020/01/symmetricom-syncserver.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

6) Path traversal

Severity: Medium

CVSSv3: 4.9 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:U/RL:U/RC:C] [PCI]

CVE-ID: CVE-2020-9030

CWE-ID: CWE-22 - Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform directory traversal attacks.

The vulnerability exists due to insufficient sanitization of user-supplied passed the FileName parameter to the syslog.php. A remote attacker can send a specially crafted HTTP request containing directory traversal sequences and read contents of arbitrary files on the system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

SyncServer: S100 - 2.90.70.3, S200 - 1.30, S250 - 1.25, S300 - 2.65.0, S350 - 2.80.1

CPE External links

https://sku11army.blogspot.com/2020/01/symmetricom-syncserver.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.

7) Path traversal

Severity: Medium

CVSSv3: 4.9 [CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N/E:U/RL:U/RC:C] [PCI]

CVE-ID: CVE-2020-9029

CWE-ID: CWE-22 - Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Exploit availability: No

Description

The vulnerability allows a remote attacker to perform directory traversal attacks.

The vulnerability exists due to insufficient sanitization of user-supplied passed via the newUserName parameter on the "User Creation, Deletion and Password Maintenance" screen (when creating a new user). A remote attacker can send a specially crafted HTTP request containing directory traversal sequences and read contents of arbitrary files on the system.

Mitigation

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

Vulnerable software versions

SyncServer: S100 - 2.90.70.3, S200 - 1.30, S250 - 1.25, S300 - 2.65.0, S350 - 2.80.1

CPE External links

https://sku11army.blogspot.com/2020/01/symmetricom-syncserver.html

Q & A

Can this vulnerability be exploited remotely?

Yes. This vulnerability can be exploited by a remote non-authenticated attacker via the Internet.

Is there known malware, which exploits this vulnerability?

No. We are not aware of malware exploiting this vulnerability.